Results 1 to 10 of 10

Thread: Downgrade Resolution on Fullscreen Mode

  1. #1

    Downgrade Resolution on Fullscreen Mode

    Hi,

    Frankly, it's a bit shame to consult the forum for such problem but I couldn't find any solution no matter what... Here is my issue; I'm using my 14" laptop with 1080p native resolution, same goes for ETQW with 16:9 aspect ratio on Linux. Recently, I have been experiencing serious frame drops which are probably related with my graphics drivers. Anyway, I decided to downgrade the game's resolution to 900p or even 720p to gain framerate and stabilize it. However, for an unknown reason, the game centers the downsized screen instead of stretching it to fullscreen. There are literally black bars around the 720p image despite being already fullscreen. I tried to tweak ~/.etqwcl/base/etqwconfig.cfg by by comparing it following source;

    http://www.tweakguides.com/ETQW_8.html

    The key value should be r_mode as it has been since the original Quake but setting it to -1 makes no difference. Here are related lines from my config;

    Code:
    seta r_customAspectRatioV "9"
    seta r_customAspectRatioH "16"
    seta r_aspectRatio "-1"
    seta r_customHeight "720"
    seta r_customWidth "1280"
    seta r_fullscreen "1"
    seta r_mode "-1"
    seta r_useSDLModes "1"
    And here is the result:

    Ekran Görüntüsü 2018-01-08 23-39-14.jpg

    Does anyone have a clue? I suspect r_useSDLModes but setting it to 0 has made no difference...

    Thanks, regards!

  2. #2

    Re: Downgrade Resolution on Fullscreen Mode

    are you sure that you have fullscreen selected in your nvidia settings under "adjust desktop size and position"?

  3. #3

    Re: Downgrade Resolution on Fullscreen Mode

    Quote Originally Posted by Pliscin-7 View Post
    are you sure that you have fullscreen selected in your nvidia settings under "adjust desktop size and position"?
    Thanks for the answer, Pliscin-7! Do you mean that option?

    900x900px-LL-35e87040_i5u243.png

    NVIDIA X Server Settings on Linux has no such option...

    9QftM.png

    As I recently tried; Half-Life, Quake (QuakeSpasm), Xash3D, Serious Sam Fusion 2017 had no such problem, but as all of them up-to-date titles that embrace SDL2 fully, that's to be expected. However, an up-to-date UDK game Unmechanical which also uses SDL2 had locked 1080p resolution problem... I will try other id Tech 4 games from that era; I have Quake 4, Prey. Let's see about that.

  4. #4

    Re: Downgrade Resolution on Fullscreen Mode

    So... I tried Prey (id Tech 4), Quake 4 (id Tech 4) and Unreal Tournament 2004 (Unreal Engine 2); all of them have exactly the same centering the downsized screen on fullscreen mode problem. Is it clear that is a Linux specific issue. I tried to switch to Intel graphics card which uses open source Mesa drivers; result is the same. It looks like I need to consult a Linux specific place; Linux users?

    Here is my system details via Steam:

    Code:
    Computer Information:
        Manufacturer:  Unknown
        Model:  Unknown
        Form Factor: Laptop
        No Touch Input Detected
    
    Processor Information:
        CPU Vendor:  GenuineIntel
        CPU Brand:  Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz
        CPU Family:  0x6
        CPU Model:  0x4e
        CPU Stepping:  0x3
        CPU Type:  0x0
        Speed:  2800 Mhz
        4 logical processors
        2 physical processors
        HyperThreading:  Supported
        FCMOV:  Supported
        SSE2:  Supported
        SSE3:  Supported
        SSSE3:  Supported
        SSE4a:  Unsupported
        SSE41:  Supported
        SSE42:  Supported
        AES:  Supported
        AVX:  Supported
        CMPXCHG16B:  Supported
        LAHF/SAHF:  Supported
        PrefetchW:  Unsupported
    
    Operating System Version:
        Ubuntu 17.10 (64 bit)
        Kernel Name:  Linux
        Kernel Version:  4.13.0-21-generic
        X Server Vendor:  The X.Org Foundation
        X Server Release:  11905000
        X Window Manager:  Metacity (Marco)
        Steam Runtime Version:  steam-runtime-beta-release_2017-10-05
    
    Video Card:
        Driver:  NVIDIA Corporation GeForce 940M/PCIe/SSE2
        Driver Version:  4.5.0 NVIDIA 384.98
        OpenGL Version: 4.5
        Desktop Color Depth: 24 bits per pixel
        Monitor Refresh Rate: 59 Hz
        VendorID:  0x10de
        DeviceID:  0x1347
        Revision Not Detected
        Number of Monitors:  1
        Number of Logical Video Cards:  1
        Primary Display Resolution:  1920 x 1080
        Desktop Resolution: 1920 x 1080
        Primary Display Size: 12.17" x 6.85" (13.94" diag)
                                                30.9cm x 17.4cm (35.4cm diag)
        Primary Bus: PCI Express 4x
        Primary VRAM: 2048 MB
        Supported MSAA Modes:  2x 4x 8x 16x 
    
    Sound card:
        Audio device: Realtek ALC236
    
    Memory:
        RAM:  3745 Mb
    
    Miscellaneous:
        UI Language:  English
        LANG:  tr_TR.UTF-8
        Total Hard Disk Space Available:  191224 Mb
        Largest Free Hard Disk Block:  87778 Mb
        VR Headset: None detected
    Last edited by REA987; 11th Jan 2018 at 08:20.

  5. #5

    Re: Downgrade Resolution on Fullscreen Mode

    you also have the fps drop in linux ?

    because i would consider the anti-virus activity to cause the drop, but if you have it in linux too ...

  6. #6

    Re: Downgrade Resolution on Fullscreen Mode

    Quote Originally Posted by REA987 View Post
    Thanks for the answer, Pliscin-7! Do you mean that option?

    900x900px-LL-35e87040_i5u243.png

    NVIDIA X Server Settings on Linux has no such option...

    9QftM.png

    As I recently tried; Half-Life, Quake (QuakeSpasm), Xash3D, Serious Sam Fusion 2017 had no such problem, but as all of them up-to-date titles that embrace SDL2 fully, that's to be expected. However, an up-to-date UDK game Unmechanical which also uses SDL2 had locked 1080p resolution problem... I will try other id Tech 4 games from that era; I have Quake 4, Prey. Let's see about that.
    yeah thats what i was talking about... but loooks all normal =/ i also have no idea then sorry

  7. #7

    Re: Downgrade Resolution on Fullscreen Mode

    It turned out to be a Nvidia Optimus + SDL1.2 issue which cannot be solved easily...

    https://www.reddit.com/r/linux_gamin...ad_of/dshizr0/

  8. #8

    Re: Downgrade Resolution on Fullscreen Mode

    I somewhat solved SDL1.2 issue by using SDL Compatibility Library but as it doesn't support threaded renderer for the time being, it's not that useful currently...

    https://www.reddit.com/r/linux_gamin...ad_of/dskudmm/

  9. #9

    Re: Downgrade Resolution on Fullscreen Mode

    From reading on Reddit I assume if you downsize your Desktop Resolution and start ETQW it will be in Fullscreen?
    If your using X11 you can use an easy tool xrandr to change desktop resolution (and refresh rate).

    Just add a line into your startup script to change the resolution before starting ETQW and changing back after existing.
    E.g.:
    xrandr -s 1024x768
    etqw-rthread.x86
    xrandr -s 1920x1080

    Note: This will mess up your Desktop Icons I think. So you may want save your current Desktop and Restore after exiting ETQW. This depends on your Desktop (XFCE etc.) but there should be many tutorials around.

  10. #10

    Re: Downgrade Resolution on Fullscreen Mode

    Quote Originally Posted by you_is_me View Post
    From reading on Reddit I assume if you downsize your Desktop Resolution and start ETQW it will be in Fullscreen?
    If your using X11 you can use an easy tool xrandr to change desktop resolution (and refresh rate).

    Just add a line into your startup script to change the resolution before starting ETQW and changing back after existing.
    E.g.:
    xrandr -s 1024x768
    etqw-rthread.x86
    xrandr -s 1920x1080
    Yeah, that seems like a sound idea. I still want to benefit from SDL 2.0 but I need to wait for answer of SDLCL's dev.

    Edit: After digging a bit, I found correct commands;

    HTML Code:
    xrandr --output eDP-1-1 --mode 1360x768
    xrandr --output eDP-1-1 --mode 1920x1080
    PS: Nvidia on a Linux laptop is a joke...
    Last edited by REA987; 13th Jan 2018 at 17:59.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •