Results 1 to 16 of 16

  Click here to go to the first staff post in this thread.   Thread: new servers are not getting there serverlicensecode anymore

  1. #1

    new servers are not getting there serverlicensecode anymore

    The authentication server is (again) not providing a license code for new servers.
    Can someone restart that still needed part please?

    If it is no trouble, maybe releasing the etqw code or releasing a version in which we can control that part ourself would be nice.

    Cheers,
    ODF

  2. #2

    Re: new servers are not getting there serverlicensecode anymore

    Can someone plz fix the authentication issue that omelet is talking about?

  3. #3

    Re: new servers are not getting there serverlicensecode anymore

    that's all controlled by Zenimax/Bethesda, their game
    Quote Originally Posted by MistaSparkle View Post
    and every time Nail comes in and ruins it

  4. #4

    Re: new servers are not getting there serverlicensecode anymore

    Thanks Nail! Do you know how I can contact them? Like do they have an email that I should use?

  5.   Click here to go to the next staff post in this thread.   #5
    Chief Technology Officer RR2DO2's Avatar
    Join Date
    Dec 2001
    Location
    London, UK
    Posts
    302
    Most Recent Awards:

    Re: new servers are not getting there serverlicensecode anymore

    Hey, I've nudged some people and the service should be up again. I can't test it myself right now (will be able to do so tomorrow) but things might well be fine again now!

    Edit: so looks like it still isn't reachable, we'll continue to investigate.
    Last edited by RR2DO2; 29th Aug 2016 at 18:34.

  6. #6

    Re: new servers are not getting there serverlicensecode anymore

    So about releasing the source under the (A)GPL.....
    Last edited by Runeforce; 29th Aug 2016 at 20:08.
    "Your bręking me hard!"

  7.   Click here to go to the next staff post in this thread.   #7
    Chief Technology Officer RR2DO2's Avatar
    Join Date
    Dec 2001
    Location
    London, UK
    Posts
    302
    Most Recent Awards:

    Re: new servers are not getting there serverlicensecode anymore

    The service has been moved to a new IP, currently awaiting DNS changes and propagation. Once that goes through it should work.

    About source code releases, id Software are the only ones that can make that happen. Due to some 3rd party components integrated in the game and external services that are used that might not be as straightforward; and unlike the original Doom source code release, where the DOS code was stripped for similar 3rd party reasons, this wouldn't be really doable for ETQW.

  8.   Click here to go to the next staff post in this thread.   #8
    Chief Technology Officer RR2DO2's Avatar
    Join Date
    Dec 2001
    Location
    London, UK
    Posts
    302
    Most Recent Awards:

    Re: new servers are not getting there serverlicensecode anymore

    I just confirmed here that the authentication is working again. Have fun playing!

  9. #9

    Re: new servers are not getting there serverlicensecode anymore

    Quote Originally Posted by RR2DO2 View Post
    I just confirmed here that the authentication is working again. Have fun playing!
    Thanks for fixing it! (Will check myself later).

    I was wondering if there is any hope to get the update server back up? So people get offered the 1.5 patch, there are so many people making threads everywhere wondering why they can't get their game to work, obviously I have been helping them, but I hate to think that people give up at the login page when they can't get it to work and think it's probably dead because they can't login/create an account.

  10.   This is the last staff post in this thread.   #10
    Chief Technology Officer RR2DO2's Avatar
    Join Date
    Dec 2001
    Location
    London, UK
    Posts
    302
    Most Recent Awards:

    Re: new servers are not getting there serverlicensecode anymore

    The update server and the key server are the same service, so that should be running as well. I can't remember exactly how the files were served, if it was just a mirror page; will have to check.

  11. #11

    Re: new servers are not getting there serverlicensecode anymore

    Quote Originally Posted by RR2DO2 View Post
    The update server and the key server are the same service, so that should be running as well. I can't remember exactly how the files were served, if it was just a mirror page; will have to check.
    Well, the updates ceased to be offered long before the server (if the same) stopped offering licenses for new servers, but good to hear that might come on again also.

  12. #12
    Dirty nader
    Join Date
    Apr 2012
    Location
    يد الجوزاء
    Posts
    69
    Most Recent Awards:

    Re: new servers are not getting there serverlicensecode anymore

    There is the same problem again.

  13. #13

    Re: new servers are not getting there serverlicensecode anymore

    Quote Originally Posted by Edzio View Post
    There is the same problem again.
    Are you sure all the ports were configured correctly?

    http://www.thesilentservice.net/ETQWDocs/mp/server.html

  14. #14
    Dirty nader
    Join Date
    Apr 2012
    Location
    يد الجوزاء
    Posts
    69
    Most Recent Awards:

    Re: new servers are not getting there serverlicensecode anymore

    Yea, I'm sure.

    Code:
    log file 'demonware_server.log' opened on 2017-6-16, 12:30:51
    2017-06-16 12:30:52 : libs/DemonWare/DemonWare-1.80/bdNet/bdNet.cpp(63): INFO: Requested port 3074, using port 3074
    2017-06-16 12:30:52 : libs/DemonWare/DemonWare-1.80/bdNet/bdNet.cpp(119): INFO: UPnP discovery successfully started, timeout: 3 seconds
    2017-06-16 12:30:55 : libs/DemonWare/DemonWare-1.80/bdNet/bdNet.cpp(249): INFO: no UPnP NATs found
    2017-06-16 12:30:55 : libs/DemonWare/DemonWare-1.80/bdSocket/bdNAT/bdNATTypeDiscoveryClient.cpp(118): INFO: Running test 1
    2017-06-16 12:30:55 : libs/DemonWare/DemonWare-1.80/bdSocket/bdNAT/bdIPDiscoveryClient.cpp(91): INFO: Public IP discovered: 195.181.209.127:3074
    2017-06-16 12:30:55 : libs/DemonWare/DemonWare-1.80/bdSocket/bdNAT/bdNATTypeDiscoveryClient.cpp(300): INFO: Reply for test 1. Start test 2.
    2017-06-16 12:30:55 : libs/DemonWare/DemonWare-1.80/bdSocket/bdNAT/bdNATTypeDiscoveryClient.cpp(318): INFO: Reply for test 2. Open NAT (or no NAT).
    2017-06-16 12:30:55 : libs/DemonWare/DemonWare-1.80/bdSocket/bdNAT/bdNATTravClient.cpp(610): INFO: Sending keep alive to introducer(s).
    2017-06-16 12:31:10 : libs/DemonWare/DemonWare-1.80/bdSocket/bdNAT/bdNATTravClient.cpp(610): INFO: Sending keep alive to introducer(s).
    2017-06-16 12:31:25 : libs/DemonWare/DemonWare-1.80/bdSocket/bdNAT/bdNATTravClient.cpp(610): INFO: Sending keep alive to introducer(s).
    2017-06-16 12:31:40 : libs/DemonWare/DemonWare-1.80/bdSocket/bdNAT/bdNATTravClient.cpp(610): INFO: Sending keep alive to introducer(s).
    Last edited by Edzio; 18th Jun 2017 at 17:50.

  15. #15

    Re: new servers are not getting there serverlicensecode anymore

    Make sure UDP: 27733 and UDP: 3074 ports are open. According to the tutorial that I posted outgoing TCP traffic should be allowed to:

    Code:
    etqw-auth.mmp3.demonware.net:3074
    
    etqw-lsg.mmp3.demonware.net:3074

  16. #16
    Dirty nader
    Join Date
    Apr 2012
    Location
    يد الجوزاء
    Posts
    69
    Most Recent Awards:

    Re: new servers are not getting there serverlicensecode anymore

    Authenticating of new servers is working again.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •