Results 1 to 4 of 4

Thread: EditSheets grid not displaying

  1. #1

    EditSheets grid not displaying

    Does anyone else have trouble getting the Atlas Texture Sheet Editor to display correctly? All I get a black view which flickers when I move the cursor across the window, see below (can't capture the flicker effect).



    All other graphical displays work fine within the SDK apart from this one. Makes is impossible to create proper texture sheets. Not sure if it's because of windows 7 or modern graphics card drivers? Can anyone think of something that could try out?

    ETQW Mediocre Club

  2. #2

    Re: EditSheets grid not displaying

    Hey Chris, I just tried the Atlas Editor and am experiencing the same problems as you. I tried experimenting with different display settings, but had little luck. Did you ever have the Atlas Editor working before? Did you create custom texturesheets when working on any of your maps?

    I've noticed that if you click "Help" -> "About..." of the Atlas Texture Sheet Editor Window that the fields "Game EXE" and "Tool DLL" appear to be backwards with no way of changing them. This may result with no way of fixing this problem if it is in fact the issue.

    I've also noticed that when running EditWorld and typing in "editSheets" from the console that there are several OpenGL functions that are not found after looking in "toolAtlasx86.dll" twice and "toolsupportx86.dll"

    Examples:
    Couldn't find proc address for: glStencilFuncSeparateATI
    Couldn't find proc address for: glStencilOpSeparateATI
    etc...

    Even running the ETQW SDK Launcher with "Options" -> "ATI Compatibility" checked does not resolve this issue for me.

    In summary, my guess is that some paths are not linking correctly or OpenGL dlls are needed that contain these missing functions. I hope this helps you.

    I don't know if this will work but.....My suggestion is that if you did not have the Atlas Texture Sheet Editor ever working, to use Gimp or Photoshop to create the texturesheet although it would take more time cause you'd have to place the diffuse,specular,normal, etc images one-by-one. Using grids would be most efficient. Even if you did this you would need to manually create the appropriate surfacetypemap (.stmap) which assigns several surface types to one texturesheet based on where the images are located.

    Another alternative would be to write a program that does this automatically, assuming my suggestion above does indeed work. Anyways, let me know what you think!

    ~Assassin4004

  3. #3

    Re: EditSheets grid not displaying

    https://sourceforge.net/projects/stame/

    Maybe that helps?
    Will have to try, but first install sdk and everything - dunno when I get time for that.
    Maybe compatibility mode helps?

  4. #4

    Re: EditSheets grid not displaying

    Thanks guys, I've used it ages ago and was working fine, the main thing about the etqw one is as Assassin4004 says is you can add 'surfacetypes' to specific areas on the texturesheet, so you can have mixture of glass and brick for example which will generate the right sound when shot on or stood on. I've tried various compatibility mode options and graphics card options but no luck so far.

    ETQW Mediocre Club

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •