Results 1 to 8 of 8

Thread: Mapshot command problems

  1. #1

    Mapshot command problems

    Hi everyone, I'm working on a custom map and didn't have this problem before when using the mapshot command. The error I'm getting is:

    idRenderWorld::RenderScene: bad FOVs: 0.724375, 0.000000

    I know the error is occuring because the last number is 0.000000 which is basically 0. How do I prevent the "y" coordinate from being zero. Do i have to change/add something in editWorld. Thanks in advance!

    ~Assassin4004

  2. #2

    Re: Mapshot command problems

    Also another question...
    When using the mapshot command for images greater than 256x256 (for example 512x512), I've found that a 512x512 image is produced but is overlayed by the current FOV on the screen.

    I used the following command.

    mapshot mapname_mapshot.tga 512

    Is there something else that needs to be set for higher resolution mapshot images. Thanks everyone!

    ~Assassin4004

  3. #3

    Re: Mapshot command problems

    I don't know why but I've been struggling with the mapshot command in my current map too and also getting my current view incorporated into the mapshot output. Anyway there are two other variables you can use to see if it makes any difference. after 512 you can also set the number of blends and the number of tiles.

    http://wiki.splashdamage.com/index.php/Mapshots

    Also note you need to be using r_mode 3 and r_aspectratio 0

    ETQW Mediocre Club

  4. #4

    Re: Mapshot command problems

    Thanks for the response Chris. I did try out those other settings but have had little luck. I got past the "bad fovs" error, it appears that when loading the map that you need to actually spawn at a spawn point. This might set up some rendering things. Once I clicked the "Spectate" button at the main menu, I could run the mapshot command and generate a 256x256 image while using the settings specified in the directions in the link you provided.

    I am still unable to get higher resolution images though :-/

  5. #5

    Re: Mapshot command problems

    Hey Chris, I have continued to have problems with the mapshot command at higher resolutions. I have no problems with the default (256x256 1 tile) mapshot command. I hope this is the same for you.

    I really wanted to have high quality mapshots, but I gave up on the mapshot command at high resolutions. Since the default mapshot command also works for tiling, I used that to my advantage and so I wrote a C# program that solved my problem:

    GUI.jpg refinery_mapshot256.png
    It stitches the images automatically together and lets you see the tile images as well. As you can see the stitched image (shown on the left) has much better quality than the default 256x256 image (shown on the right)

    ~Assassin4004
    Last edited by Assassin4004; 23rd Feb 2015 at 09:23.

  6. #6

    Re: Mapshot command problems

    Yes, 256 works for me too. I also have problems with the sheet editor too, wonder if it's all related to modern video cards/drivers?

    ETQW Mediocre Club

  7. #7

    Re: Mapshot command problems

    Hey everyone! I'm having problems taking a mapshot that I didn't notice before. My entire map's size is 40960x40960. The main gameplay area is 32768x32768. When I take a mapshot to create commandmaps, it only obtains an image covering the 32768x32768 area and therefore I can't form my out of bounds commandmap. Is there a way to change the FOV of the mapshot command to include the entire map's size? Or is there another way to obtain this image that doesn't involve using a mapshot command.

    I looked at Donnovan's Glory of the Week map as an example and he somehow has the entire map's mapshot.

    Thanks in advance!

    /*****SOLVED*****/
    Apparently a megatexture must be applied to the terrain model in order for it to take a 40960x40960 FOV for the mapshot command. Not entirely sure why!
    Last edited by Assassin4004; 7th Nov 2015 at 20:35. Reason: Solved!

  8. #8

    Re: Mapshot command problems

    Does anyone know any command to hide things like vehicles/players/bots when taking a mapshot?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •