Page 4 of 5 FirstFirst ... 2 3 4 5 LastLast
Results 61 to 80 of 90

Thread: ET OSX 2.60d

  1. #61

    Re: ET OSX 2.60d

    ok - now I tried to go into the LZ server to play ET after manually updating PB. And it let me play a few seconds until I tried to respawn, and then it kicked me due to PB not liking the allow extensions I added to the apple script to launch the app.

    I was looking for the auto config exec in the library under application support, but that doesn't even exist on my mac. Not sure if I need to do a full install again (there goes my xp).

  2. #62

    Re: ET OSX 2.60d

    ok so I've manually updated PB, reinstalled manually ET to the 2.60d dmg (by moving over the files one by one since I had other etpro, shrub, jaymod, etc), and it seemed to go fine except I kept getting the error msg that pb kicked me because of cvar r_allowExtensions 0.

    So, I tried to set up my autoexec.config in the application support folder (since it was missing and since I'm on AMD on the new iMac). and I put the two lines that clovist suggested.

    Ran it again, worked for a few seconds, and then it kicked me again:
    cvar r_allowExtensions 0

    So, I then changed the autoexec.config to r_allowExtensions 1 and verify that all the config files in my ET folder under applications do not say have 0 assigned to that parameter. I think they were all 1, but had the word "unsafe" next to it (not sure why??).

    I then run it again, and I get
    cvar r_allowExtensions 0

    Anyone know why? It's making me batty.

  3. #63

    Re: ET OSX 2.60d

    Here's the error in detail:
    Cvar r_allowextensions (-0) must be EQUAL TO 1

    I've tried setting openGL to enabled in the system controls as well as in the console itself during the game. Mac crashed out of ET with some strange error message that was in tiny font that I could not read.

  4. #64

    Re: ET OSX 2.60d

    Quote Originally Posted by Krauersaut View Post
    Crashes for me with:

    Wolfenstein cannot continue
    aglGetError: invalid enumeration at /Users/ttimo/SVN/ET/src/mac/mac_glimp.cpp line 895

    Worked fine with Snow Leopard.

    I tried the autoexec.cfg too and I'm still having issues. Got that error msg as well as getting kicked by PB with that set allowextensions = 0 error.

    I'm on a new Imac 27" with AMD card, so I'm like Kauersaut - I can't use th gfxcardstatus app.

  5. #65

    Re: ET OSX 2.60d

    Quote Originally Posted by Krauersaut View Post
    Crashes for me with:

    Wolfenstein cannot continue
    aglGetError: invalid enumeration at /Users/ttimo/SVN/ET/src/mac/mac_glimp.cpp line 895

    Worked fine with Snow Leopard.
    I got the same error. No one of the solutions has worked, only run in Wineskin, but is unplayable

    Any suggestion is aweshome!

    I apologize for my poor english

    ______________________________________________

    iMac10,1 Intel Core 2 Duo 3,06 GHz 8Gb RAM

  6. #66

    Re: ET OSX 2.60d

    you could PM TTimo here or possibly get in touch with Brad Oliver at insidemacgames.com forums, both have worked extensively with RTCW and W:ET, one of them would likely know what probs there are
    Quote Originally Posted by MistaSparkle View Post
    and every time Nail comes in and ruins it

  7. #67

    Re: ET OSX 2.60d

    I am seriously getting to the point where I'm thinking I'll have to give up ET (gasp), wait for a Lion update that may or may not fix the issue, or just partition my drive for Snow Leopard and play there. I'd rather have a solution though on Lion right now though, as it should work. I'm so regretting getting Lion. It has caused nothing but issues, and not sure if it was worth the early adoption.

  8. #68

    Re: ET OSX 2.60d

    How to run Wolfenstein ET on OS X Lion: (Tested on Macbook Pro 2011)

    1. Download (Wolfenstein Enemy Territory 2.60d)
    2. Drag the Wolfenstein ET folder to your Applications folder.
    3. Run the punkbuster installer.
    4. In ~/Library/Application Support/ create "Wolfenstein ET" folder and therein "etmain" folder.
    5. Download a punkbuster etkey
    6. Put the etkey in the following location: ~/Library/Application Support/Wolfenstein ET/etmain
    7. In ~/Library/Application Support/Wolfenstein ET/etmain/ create a file: "autoexec.cfg"
    8. Paste the two lines of this file:

    seta r_colorbits "32"
    set r_allowExtensions 0


    9. Run ET.

    10. Set screen resolution via the following commands in the game console (press ~ after launching the game to view game console):

    /r_customwidth XXXX
    /r_customheight XXXX
    /r_mode -1

  9. #69

    Re: ET OSX 2.60d

    The 10. point will cut the screen vertically, you'll see just 1/2 of your gun, adjusting cg_fov can help but does not everything...

    And r_allowExtentions 0 does not make clients kicked by PunkBuster?

  10. #70

    Re: ET OSX 2.60d

    Siri,

    This solution are old. and don´t work for me.

    Cheers.

  11. #71

    Re: ET OSX 2.60d

    Hi all,
    r_allowExtensions 0 work great but it make the game very laggy :s

    i can't keep my 125 fps stable (like it was on snow leo), i tried many resolution (from 1920 x 1200 to 800x600), lowering all r_ (anyway that my favorite set ^^), disable all "fps eater" in cg_ ....

    so... UP !!

    thanks all and hope new solutions..
    Last edited by tribe; 16th Feb 2012 at 05:56.

  12. #72

    Re: ET OSX 2.60d

    This is a nice game guys. I played this game a long time ago. Will you tell me any updates for me about this game ???

  13. #73

    Re: ET OSX 2.60d

    You can try ET:Legacy http://www.etlegacy.com/download

    And since that is currently not full featured,
    Or you can try this to start the original ET: http://redsaurus.net/blog/?p=112#more-112

  14. #74

    Re: ET OSX 2.60d

    This is going to sound really dumb but how exactly do you get to /Library/Application Support/Wolfenstein ET/etmain? because with my mac it doesn't show what files are leading to what for example, if i open my applications page and go to W:ET does that classify as my library? I am not very familiar with finding things easily on macs. I understand that on a non mac pc you can see what folders are there but i am having trouble knowing if my et key is in the right place. I also posted the crash report in my thread that i just posted about startup problems. PLEASE I love W:ET and havent been able to play in a while and i really want to play! Thanks

  15. #75

    Re: ET OSX 2.60d

    Process: Wolfenstein ET [1220]
    Path: /Applications/Wolfenstein ET/Wolfenstein ET.app/Contents/MacOS/Wolfenstein ET
    Identifier: com.activision.rtcw_et
    Version: 2.60b4 (2.60b4)
    Code Type: X86 (Native)
    Parent Process: launchd [174]
    Responsible: Wolfenstein ET [1220]
    User ID: 501

    Date/Time: 2014-03-02 16:20:45.406 -0500
    OS Version: Mac OS X 10.9.2 (13C64)
    Report Version: 11
    Anonymous UUID: 27F5589F-3E2C-C516-93E1-7C39D2E8E9D9


    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000

    Dyld Error Message:
    Symbol not found: _OTSetNonBlocking
    Referenced from: /Applications/Wolfenstein ET/Wolfenstein ET.app/Contents/MacOS/Wolfenstein ET
    Expected in: /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0 dyld 0x8fed40b5 dyld_fatal_error + 1
    1 dyld 0x8fed6de8 dyld::bindLazySymbol(mach_header const*, unsigned long*) + 72
    2 dyld 0x8fee734e stub_binding_helper_interface2 + 20
    3 com.activision.rtcw_et 0x000e009a 0x1000 + 913562
    4 com.activision.rtcw_et 0x000e2868 0x1000 + 923752
    5 com.activision.rtcw_et 0x0007c2b0 0x1000 + 504496
    6 com.activision.rtcw_et 0x000e3c25 0x1000 + 928805
    7 com.activision.rtcw_et 0x00002456 0x1000 + 5206
    8 com.activision.rtcw_et 0x0000237d 0x1000 + 4989

    Thread 1:
    0 libsystem_kernel.dylib 0x990a3046 __workq_kernreturn + 10
    1 libsystem_pthread.dylib 0x9a219dcf _pthread_wqthread + 372
    2 libsystem_pthread.dylib 0x9a21dcce start_wqthread + 30

    Thread 2:: Dispatch queue: com.apple.libdispatch-manager
    0 libsystem_kernel.dylib 0x990a3992 kevent64 + 10
    1 libdispatch.dylib 0x9371d8ad _dispatch_mgr_invoke + 238
    2 libdispatch.dylib 0x9371d546 _dispatch_mgr_thread + 52

    Thread 3:
    0 libsystem_kernel.dylib 0x990a3046 __workq_kernreturn + 10
    1 libsystem_pthread.dylib 0x9a219dcf _pthread_wqthread + 372
    2 libsystem_pthread.dylib 0x9a21dcce start_wqthread + 30

    Thread 4:
    0 libsystem_kernel.dylib 0x990a3046 __workq_kernreturn + 10
    1 libsystem_pthread.dylib 0x9a219dcf _pthread_wqthread + 372
    2 libsystem_pthread.dylib 0x9a21dcce start_wqthread + 30

    Thread 0 crashed with X86 Thread State (32-bit):
    eax: 0x8ff070f8 ebx: 0x00006d38 ecx: 0x00000000 edx: 0x8ff2f084
    edi: 0x8ff2f084 esi: 0x8fed51e3 ebp: 0xbffff718 esp: 0xbffff6fc
    ss: 0x00000023 efl: 0x00000246 eip: 0x8fed40b5 cs: 0x0000001b
    ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x0000000f
    cr2: 0x027ee000

    Logical CPU: 3
    Error Code: 0x00000000
    Trap Number: 3

    This is my crash report, any help?

  16. #76

    Re: ET OSX 2.60d

    As far as I know ET does not work with 10.9x Mavericks, and 10.9.2 is what you got according to your crash log.

    How to view Library Folder: http://www.macworld.com/article/2057...mavericks.html

    And if the solution from RedSaurus does not work - you don't really need to try more - it just will not work.
    Best bet is to get etlegacy running or wineskin (probably laggy), or bootcamp ftw.
    http://redsaurus.net/blog/?p=156


    Quote Originally Posted by ailmanki View Post
    You can try ET:Legacy http://www.etlegacy.com/download

    And since that is currently not full featured,
    Or you can try this to start the original ET: http://redsaurus.net/blog/?p=112#more-112

  17. #77
    Junior Member
    Join Date
    Sep 2014
    Posts
    2

    Re: ET OSX 2.60d

    Hi, my Name is dirk and i come from Germany. Since 1996 i was a Player of e.t. via 2009. Now i will come back. I have Windows 8.1. Can you help me to install the fullversion with all of items please? Thanks and greatings from dirk2309@gmx.de

  18. #78

    Re: ET OSX 2.60d

    Quote Originally Posted by binolas View Post
    Hi, my Name is dirk and i come from Germany. Since 1996 i was a Player of e.t. via 2009. Now i will come back. I have Windows 8.1. Can you help me to install the fullversion with all of items please? Thanks and greatings from dirk2309@gmx.de
    http://www.splashdamage.com/content/...nemy-territory

    Just don't install it on system C:\ partition and everything should run smoothly.

  19. #79
    Junior Member
    Join Date
    Sep 2014
    Posts
    2

    Re: ET OSX 2.60d

    Very thanks:-)) Dirk

  20. #80
    Junior Member
    Join Date
    Mar 2015
    Posts
    1

    Problem with starting ET in OS X

    Hello,

    I have downloaded OS X 2.60d dmg at splashdamage links http://www.splashdamage.com/content/...nemy-territory and after I tried to start ET it just shows console for a while and then crashed. I tried to find some instructions and followed http://www.jffgames.com/how-to-insta...ry-on-mac-osx/ with anything but small progress. I snapshot the message (in attachment) – it shows message after following the other website, the only change in console before was that even autoexec.cfg did not exec.

    Did anybody encounter the same problem? Do I miss some files? Please help.
    Attached Images Attached Images

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •